NUnitTfs Version 2.0 Alpha 1 for TFS2010 does not display unit test results as build step

Nov 19, 2010 at 2:47 PM
Edited Nov 19, 2010 at 2:55 PM

Hi all,

I'm trying to integrate the publishing of the NUnit test results in the TFS output display.As I read on nunit4teambuild WebPage, running mstest is no more necessary. So I just execute NUnitTfs.exe with the necessary parameters.

Everything looks working fine (after trying a lot) :

"C:\bin\NUnitTfs Version 2.0 Alpha 1\NUnitTfs.exe" -n TestResult.xml -t eFDC -b Build-eFDC.Stat_20101119.3 -v 2010
  Loading NUnit Output from TestResult.xml...
  Transforming NUnit output to .trx file...
  Adding build information to .trx file...
  Publishing .trx file...
  Checking test run does not exist...
  Reading users identity...
  Creating test run...
  Creating test results...
  Updating test run with details...
  Uploading test run details...
  Uploading assemblies...
  Updating test results with details...
  Uploading test result details...
Done Building Project "C:\Builds\1\eFDC\BISTel.eFDC.Stat.csproj" (default targets).

Build succeeded.

BUT the unit test results are not displayed in the Build steps after Build. I only can see following steps:

  1. Create Workspace
  2. Get Workspace
  3. Compiling sources for AnyCPU/Release
  4. Assosiate Changesets and Work Items
  5. Building project "BISTel.eFDC.Stat.csproj".
  6. Copy Files to Drop Location

All are green, but I can not see the 5 tests that were executed. Logfile:

Tests run: 5, Errors: 0, Failures: 1, Inconclusive: 0, Time: 0,0760097 seconds
    Not run: 0, Invalid: 0, Ignored: 0, Skipped: 0

What did I make wrong? OK, I did not set it up as workflow like pekkah suggested it here: http://nunit4teambuild.codeplex.com/Thread/View.aspx?ThreadId=214846. But it should also work with command line execution, right?

Best regards, Mayoar

Mar 30, 2011 at 9:05 PM

Same problem here.