1

Closed

Could not find file 'UNNAMED'

description

Don't know what is going on. Could you help?

C:\Users\myuser>C:\Builds\1\MyProject\ContinuousIntegration\Sources\MyProject\devel\main\Dependencies\nunit4teambuild\NUnitTfs.exe -n C:\Builds\1\MyProject\ContinuousIntegration\Binaries\nunit-tests.xml -t MyProject -b "ContinuousIntegration_20110804.10" -v 2010

Loading NUnit Output from C:\Builds\1\MyProject\ContinuousIntegration\Binaries\nunit-tests.xml...
Transforming NUnit output to .trx file...
Adding build information to .trx file...
Publishing .trx file...
Checking test run does not exist...
Reading users identity...
Creating test run...
Creating test results...
Updating test run with details...
System.IO.FileNotFoundException: Could not find file 'UNNAMED'.
File name: 'UNNAMED'
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileInfo.get_Length()
at KWatkins.NUnitTfs.Tfs2010.Publisher2010.<>c__DisplayClassc.<UpdateTestRunWithTmiRunAndAssemblies>b__9(FileInfo file) in C:\Users\Kevin Watkins\Documents\Visual Studio 10\Projects\NUnitTFS\NUnitTFS\Tfs2010\Publisher2010.cs:line 150
at System.Linq.Enumerable.WhereSelectArrayIterator2.MoveNext()
at System.Linq.Buffer
1..ctor(IEnumerable1 source)
at System.Linq.Enumerable.ToArray[TSource](IEnumerable
1 source)
at KWatkins.NUnitTfs.Tfs2010.Publisher2010.UpdateTestRunWithTmiRunAndAssemblies(TestRun testRun, XDocument trx) in C:\Users\Kevin Watkins\Documents\Visual Studio 10\Projects\NUnitTFS\NUnitTFS\Tfs2010\Publisher2010.cs:line 149
at KWatkins.NUnitTfs.Tfs2010.Publisher2010.PublishToTfs(XDocument trx) in C:\Users\Kevin Watkins\Documents\Visual Studio 10\Projects\NUnitTFS\NUnitTFS\Tfs2010\Publisher2010.cs:line 44
at KWatkins.NUnitTfs.Program.Main(String[] args) in C:\Users\Kevin Watkins\Documents\Visual Studio 10\Projects\NUnitTFS\NUnitTFS\Program.cs:line 29

The nunit result is generated in this way:
C:\Builds\1\MyProject\ContinuousIntegration\Sources\MyProject\devel\main\Dependencies\nunit\bin\nunit-console.exe C:\Builds\1\MyProject\ContinuousIntegration\Binaries\MyProject.DataAccess.Tests.dll C:\Builds\1\MyProject\ContinuousIntegration\Binaries\MyProject.Domain.Tests.dll C:\Builds\1\MyProject\ContinuousIntegration\Binaries\MyProject.UI.Tests.dll C:\Builds\1\MyProject\ContinuousIntegration\Binaries\MyProject.Utility.Tests.dll /xml:C:\Builds\1\MyProject\ContinuousIntegration\Binaries\nunit-tests.xml /framework:net-2.0
Closed Apr 25, 2012 at 11:48 AM by rbanks54

comments

RolfT wrote Aug 4, 2011 at 1:01 PM

Upgraded from NUnit 2.4.1 to NUnit 2.5.10 fixed this problem.

wrote Nov 24, 2011 at 2:59 AM

Associated with changeset 63603.

rbanks54 wrote Nov 24, 2011 at 3:08 AM

Fixed for NUnit 2.4.x as well. Hopefully I didn't break anything else with the change :-P (I need to keep messing around with NUnit versions to check it and I may have missed something)